Aplikace Lístky

Obsah

1. Co je aplikace Lístky?
O firmě Barda SW,HW
Proč aplikace vznikla
Co Vám aplikace Lístky umožní?
Již používám program Jídelna, co mi přinese aplikace Lístky?
Registrace
2. Instalace
Spuštění instalace
Nastavení spolupráce s programem Jídelna
Spuštění programu
3. Práce s aplikací Lístky
Hlavní okno
Zadávání jídel
Použití databáze jídel
Nastavení aplikace Lístky
Nastavení počtu a druhů jídel
Export jídelníčku na Internet
Tisk jídelníčku
Zpracování souboru iObjednávek
Webová prezentace jídelny
Tisk seznamu ID
Aplikace Help Desk
Aktualizace programu přes Internet
Možné potíže a jak je vyřešit
4. Dodatky
Co je nového v této verzi aplikace Lístky
Kontakty

1.Co je aplikace Lístky?

O firmě Barda SW,HW

Se nejvíce dozvíte na jejích www stránkách, konkrétně na http://www.barda.cz/firma.php, na těchto stránkách je také možné si aplikaci zdarma stáhnout a vyzkoušet.



Zpátky na obsah

Proč aplikace vznikla

Koncem září 2005 jsme pro společnost Jídelny.cz vytvořili aplikaci zobrazující jídelní lístky našich zákazníků. Tento počin měl velmi kladný ohlas a vyrojilo se mnoho ŠJ, které též chtěly vystavovat své jídelní lístky. Proto jsme vytvořili tuto jednoduchou aplikaci pro Windows, která jim to umožní.



Zpátky na obsah

Co Vám aplikace Lístky umožní

Aplikace Lístky Vám umožní snadno a rychle vytvořit jídelní lístek, se vším, co k tomu patří. Můžete si nastavit různé počty jídel v různých dnech týdne, vybrat, která jídla chcete a která nechcete umístit na Internet. K urychlení práce Vám poslouží rozsáhlá databáze jídel, z které si rozhodně lze vybrat. Dále aplikace umožňuje tisknout jídelníčky podle různých šablon. Hlavním účelem však zůstává umisťování jídelních lístků na Internet. Věříme, že tímto snadným krokem znatelně zvednete prestiž své jídelny.

Zpátky na obsah

Již používám program Jídelna, co mi přinese aplikace Lístky?

Aplikace Lístky přenáší Vám dobře známé úkony do atraktivnějšího a pohodlnějšího prostředí. Přechod je snadný, uživatelské rozhraní aplikace Lístky je intuitivní a sdílí s programem Jídelna veškerá data a nastavení, takže se nemusíte o nic starat. Velký skok také zaznamenala kvalita tisku, která je v aplikaci Lístky výrazně lepší a poskytuje větší výběr různých šablon. Nyní máte také možnost exportovat jídelníček rovnou na Internet, bez odesílání souboru mailem.

Zpátky na obsah

Registrace

Aplikace Lístky je Vám k dispozici k vyzkoušení zcela zdarma. Pokud ji ovšem chcete využívat naplno, je potřeba se zaregistrovat. Registrovat se můžete on-line na www.barda.cz/reg_karta.php nebo písemně poštou, faxem, e-mailem a nebo telefonicky. Kontakty naleznete zde , cena registrace se odvíjí od aktuálního ceníku firmy Barda.
To se samozřejmě netýká uživatelů programu Jídelna, protože ti již registrovaní jsou.

Zpátky na obsah

2.Instalace

Spuštění instalace

Z instalačního CD nebo po stažení z internetu spusťte soubor listkyinst.exe. Řiďte se pokyny na obrazovce. Pokud používáte operační systém Windows 95 nebo Windows 98 bude potřeba spolu s aplikací Lístky nainstalovat nové ovladače Microsoft Data Access Components. Instalátor Vám tuto možnost sám nabídne.

Zpátky na obsah

Nastavení spolupráce s programem Jídelna

Pokud používáte program Jídelna verze 6 a vyšší, zaškrtněte příslušnou volbu na instalačním panelu. Na dalším panelu zadejte cestu k datovém úložišti aplikace Jídelna. Obvykle bývá ve složce data v instalačním adresáři programu Jídelna (tedy např.: C:\Jidelna6\Data). Pokud adresář nemůžete najít, kontaktujte naší technickou podporu. Není ovšem také na závadu, pokud v takovém případě volbu sdílení dat prozatím vypnete a zapnete jí později z aplikace Lístky, až si budete jisti, kde se datová složka programu Jídelna nachází.
Nastavení cesty k datům najdete v menu Soubor->Nastavení na kartě Další nastavení.

Zpátky na obsah

Spuštění programu

Po dokončení instalace spustíte program Lístky buď přes instalátorem vytvořené zástupce na ploše a v menu Programy nebo přímo z Vámi vybraného instalačního adresáře, soubor Lístky.exe. Pokud nemáte nainstalovaný program Jídelna nebo jste se rozhodli pro oddělená datová úložiště, budete při prvním spuštění vyzváni k vyplnění údajů o Vaší jídelně. Více v sekci Nastavení aplikace Lístky.



Zpátky na obsah

3. Práce s aplikací Lístky

Hlavní okno


Na obrázku vidíte hlavní okno aplikace tak, jak se zobrazí při běžném spuštění.

  1. Aplikační lišta - zde vidíte název své jídelny a své registrační číslo
  2. Výběr data. Zde vyberete den, který chcete editovat.
  3. Tlačítka pro rychlou navigaci. Více
  4. Ve sloupci Typ vidíte jednotlivé typy jídel. (O nastavení typů jídel se víc dozvíte v sekci nastavení.)
  5. Vlastní datová pole. Zde vidíte jednotlivé složky jídel na daný den, plus jestli si lze toto jídlo objednat a jestli bude zasláno na Internet.
Šířku sloupců výpisu jídel můžete přizpůsobit svým potřebám posunutím oddělovací čáry myší.

Detail na výběr data. Tento kalendář se objeví, pokud klepnete myší na malou šipku na pravém konci výběru datumu.
Malými šipkami na stranách kalendáře se posunete o měsíc.

Dále jsou v hlavním okně ještě nabídky Soubor, Nástroje a Nápověda.
Detail nabídky Soubor:

Jak vidíte, je zde pět položek:
  1. Nastavení
  2. Export
  3. Aktualizace
  4. Tisk
  5. Konec
Volba Konec ukončí aplikaci Lístky. O ostatních se dočtete v příslušných sekcích manuálu.
Detail nabídky Nástroje:

V tomto menu najdeme tři položky:
  1. Zpracování iObjednávek
  2. Webová prezentace jídelny
  3. Tisk seznamu ID
Posledním objektem na hlavní liště je nabídka Nápověda:

  1. Volba Manuál otevře tuto dokumentaci.
  2. Volba Připojit na Help Desk spustí aplikaci Help Desk.
  3. Volba O Aplikaci zobrazí stručné informace o aplikaci a firmě Barda SW,HW

Tlačítka pro rychlou navigaci

Tlačítka pro rychlou navigaci Vám umožňují se rychleji posouvat mezi daty.

Zleva doprava to jsou:
<< : Posun o týden vzad (klávesová zkratka Ctrl + PageDown nebo Ctrl + Šipka dolů)
< : Posun o den vzad (klávesová zkratka PageDown nebo Ctrl + Šipka vlevo)
> : Posun o den vpřed (klávesová zkratka PageUp nebo Ctrl + Šipka vpravo)
>> : Posun o týden vpřed (klávesová zkratka Ctrl + PageUp nebo Ctrl + Šipka nahoru)



Zpátky na obsah

Zadávání jídel

Pokud chcete editovat jídlo, stačí dvakrát poklepat myší na řádku s příslušným typem jídla nebo řádku zvolit a stisknout F5 či Enter.
Objeví se Vám následující dialog:

Na horní liště vidíte datum a typ jídla, které právě upravujete. Do jednotlivých kolonek je možné buď přímo vepsat název jídla nebo stiskem tlačítka Vybrat či klávesou F5 použít databázi jídel.
Stisknutím tlačítka Uložit uložíte provedené změny do databáze, tlačítko Zrušit naopak všechny změny, jež jste nyní v jídle udělali zruší.


Pro práci s jídly jsou k dispozici i další nástroje. Menu nástrojů zobrazíte klepnutím pravým tlačítkem myši na výpis jídel v hlavním okně:

Volba Kopírovat vloží do schránky obsah aktuálně vybrané buňky. (lze také provést klávesovou zkratkou Ctrl+C)
Volba Kopírovat celé jídlo vloží do schránky obsah celého aktuálně vybraného jídla. (lze také provést klávesou F9)
Volba Vložit vloží obsah schránky do aktuálně vybrané buňky/řádku - podle obsahu schránky. (lze také provést klávesovou zkratkou Ctrl+V)
Volba Smazat celé jídlo smaže celý obsah aktuálně zvoleného jídla. (lze také provést klávesou Delete)



Zpátky na obsah

Použití databáze jídel

Pokud v dialogu úpravy jídla stisknete F5 nebo zmáčknete tlačítko vybrat, dostanete se do databáze jídel.
Objeví se Vám tento dialog:

Jak jste si pravděpodobně všimli, jídla jsou kvůli přehlednosti rozdělena do kategorií.

  1. Sloupec s názvy kategorií
  2. Posuvník, kterým se posouváte v rámci seznamu kategorií.
Dvojím poklepáním myší, stiskem Enteru či klávesy F5 se dostanete do dialogu výběru jídla (pochopitelně v rámci příslušné kategorie.)

Dialog výběru jídla funguje téměř identicky, jako dialog výběru kategorie. Vybrané jídlo se pak objeví v příslušné kolonce v dialogu editace jídla.



Zpátky na obsah

Nastavení aplikace Lístky

K nastavení aplikace se dostanete přes nabídku Soubor v hlavním okně aplikace.
Jak vidíte, nastavení je nově rozděleno do tří karet:

Na první kartě můžete vyplnit údaje o své jídelně. Za zmínku stojí zejména název, který nelze zadat přímo, ale počítá se z Licenčního a registračního čísla, které dostanete při své registraci.
Pro zkušební účely je možné zadat registrační číslo "00000", pak běží program v neregistrovaném režimu a je možné si jej vyzkoušet. I z neregistrované verze je možné exportovat jídelníček na web, ale všechny neregistrované kopie mají na stránkách dohromady jen jedno místo a tak počítejte s tím, že Váš jídelníček brzy přepíše někdo, kdo si to bude také chtít vyzkoušet.
Tlačítko Registrace po Internetu Vás odkáže na příslušnou stránku firmy Barda.
Pro správnou funkci exportu je nutné mít vyplněné položky Ulice, Obec a PSČ. Pokud tyto položky nebudou správně vyplněné, aplikace Vás na to upozorní.

Druhá karta je věnována nastavení Internetových objednávek. V závislosti na vámi aktivovaných modulech programu Jídelna mohou být některé položky neaktivní.
Zpráva pro uživatele iObjednávek se zobrazí při otevření stránky s jídelníčkem v internetovém prohlížeči. Můžete ji použít například pro informování o dočasné omezení provozu jídelny či pro upozornění na nové služby nebo na cokoliv jiného.
Pole "Zpráva platí do" určuje, do kdy se bude Vámi zadaná zpráva objevovat na internetu. Tedy po jakém datu už zpráva nemá smysl. (například, pokud chcete upozornit na omezený provoz v průběhu podzimních prázdnin, zadáte sem datum posledního prázdninového dne) Pokud zpráva není časově omezena, zaškrtněte, že zpráva platí do odvolání.

Na poslední kartě lze změnit cestu k datům, například kdybyste později nainstalovali program Jídelna a chtěli byste, aby s ním aplikace Lístky data sdílela.
Volba sledovat nové verze při spuštění je vhodná zejména pro uživatele s pevným připojením k Internetu. Aplikace pak vždy při svém startu kontroluje, jestli není k dispozici aktualizace a případně Vám ji nabídne.
A volbě Nastavení jídel se budeme věnovat v další kapitole.



Zpátky na obsah

Nastavení počtu a druhů jídel

V nastavení jídel můžeme měnit, který den si lze objednat která jídla (většinou to jsou také ty, které se daný den vaří) a která z nich se zasílají na Internet.
Nastavení jídel je přístupné z okna Nastavení, tlačítko Nastavení jídel.
Zobrazí se nám následující dialog:

V horní části (1) jsou uvedeny jednotlivé dny v týdnu a v datové části(2) vidíme jednotlivé druhy jídel a které dny si je lze objednat.
Tlačítky v dolní části dialogu můžeme smazat nebo upravit zvolený druh jídla, případně přidat nový.
Při úpravě nebo přidávání druhu jídla se nám objeví tento dialog:

Zde můžeme snadno zvolit vše podstatné o jídle - které dny si ho lze objednat, jak se bude nazývat a které dny je zveřejňováno na Internetu.



Zpátky na obsah

Export jídelníčku na Internet

Od verze 7.141 přešla aplikace Lístky na export v novém formátu. Co to pro vás znamená? Zaprvé se mění přípona generovaných souborů (dříve .exp, nyní .zip) a hlavně je podporován iAjs Full (tedy export strávníků a objednávek). Jedinou výjimkou je prozatím export spotřebního koše, který bohužel nejde z aplikace Lístky provést. Využití iAjs Full je samozřejmě podmíněno aktivací modulu iAjs Full v programu Jídelna. Další změnou je, že se již na Internet exportují celé názvy jídel tak, jak byly zadány v nastavení jídel, a ne pouze jejich čísla. Tato volba přináší větší možnosti zejména pro mateřské školy.

V nabídce soubor zvolte export a objeví se Vám dialog exportu:

Zde vyberte datum a počet dní, na které se má jídelníček exportovat. Jak vidíte, máte nyní dispozici dva způsoby exportu:

  1. Export na web - jídelníček je přímo aplikací Lístky vložen do internetového objednávkového systému. Tento způsob exportu doporučujeme, protože pro Vás představuje nejmenší množství práce - po zmáčknutí tohoto tlačítka se lístek okamžitě zobrazí stránkách objednavky.jidelna.cz a aplikace Lístky Vám vypíše zprávu o průběhu zpracování lístku naším systémem. (volba "Otevřít e-mail" v tomto případě nemá žádný vliv)
    Další důležitou výhodou je, že při exportu přímo na web jsou data šifrována a tak jsou případné osobní údaje (zejména údaje strávníků při exportu dat iAjs Full) lépe chráněny.
  2. Export do souboru - tedy export, který znáte ze starších verzí aplikace Lístky - po zmáčknutí tohoto tlačítka se Vám objeví dialog uložení souboru:

V žádném případě soubor nepřejmenovávejte, pak by se Váš jídelníček nemohl zobrazit na Internetu. Soubor uložte.
Pokud jste zaškrtli volbu "Otevřít e-mail", aplikace spustí Vašeho poštovního klienta a předvyplní mailovou zprávu. Drtivá většina poštovních klientů bohužel nepodporuje předvyplnění přílohy, a proto musíte vyexportovaný jídelníček ke zprávě přiložit ručně.
Pokud ale nemáte na počítači, kde běží aplikace Lístky, přístup na internet, nebo z jakéhokoliv důvodu nechcete jídelníček odeslat ihned, odešlete soubor později jako přílohu e-mailem na adresu listek@jidelna.cz Do několika minut se Váš jídelníček zobrazí na stránkách objednavky.jidelna.cz

Poznámka: Aby export fungoval, musíte mít v nastavení aplikace Lístky vyplněnu adresu Vaší jídelny.



Zpátky na obsah

Tisk jídelníčku

V nabídce Soubor vyberte Tisk. Objeví se Vám následující dialog:

Zde vyberte datum a počet dní, na které chcete jídelníček vytisknout (obdobně jako při exportu)
Běžně se tisknou pouze jídla, u kterých bylo zadáno, že je lze vybrat. Pokud chcete tisknout všechna jídla, zakšrtněte volbu Tisknout i jídla, která nelze vybrat.
Poté vyberte tiskovou šablonu, kterou chcete použít. Tiskové šablony mají příponu '.rep'. Standardní šablony jsou umístěny v adresáři, kam jste aplikaci nainstalovali, ve složce Sablony. Stisknutím tlačítka Procházet otevřete dialog výběru souboru, kde můžete zvolit, kterou šablonu hodláte použít.
Spolu s programem se instalují tři základní druhy šablon:

  1. Šablona pro tisk jídel po dnech (PoDnech.rep) - nejběžnější šablona, vytiskne jídla seskupená po dnech.
  2. Šablona pro tisk jídel po druzích (PoDruzich.rep) - jídla nejsou seskupena po dnech, ale po druzích.
  3. Šablona pro zkrácený výpis jídel (PoDnechZkracene.rep) - vhodné zejména pro zařízení, kde se vaří více jak jednou denně. Každý typ jídla je spolu se svým názvem vytištěn na pouze jeden řádek, bez rozdělení na jednotlivé části - koho by zajímala polévka u svačiny, že?
    Další tiskové šablony budou k dispozici ke stažení na stránkách firmy Barda SW,HW. Jsme schopni Vám vytvořit i šablonu přímo pro Vás - na zakázku, stačí nás kontaktovat.
Stisknutím tlačítka Náhled zobrazíte okno náhledu:

V hlavním okně náhledu si můžete prohlédnout, jak bude vytištěný jídelníček vypadat. Kromě toho zde naleznete i několik tlačítek pro ovládání náhledu:
  1. Posouvání po stranách náhledu. Můžete buď přímo zadat číslo stránky nebo se posunout na začátek náhledu, na předchozí stranu, na další stranu nebo na konec náhledu.
  2. Tisk jídelníčku (více viz dále)
  3. Tisk jídelníčku do souboru, odeslání jídelníčku e-mailem ve formátu pdf. V současné verzi bohužel nejsou tyto funkce plně podporovány kvůli problémům s českými znaky.
  4. Možnosti stránky - zde jsou přístupná některá další nastavení tiskové šablony. Měnit toto nastavení doporučujeme pouze zkušeným uživatelům.
  5. Nastavení velikosti náhledu - reálná velikost, upravit velikost podle okna a zobrazit celou stránku najednou.
  6. Zmenšení / zvětšení náhledu
  7. Uzavření okna náhledu


Po stisknutí tlačítka Tisk se Vám zobrazí dialog tisku: (vzhled se může lišit podle verze Windows na Vašem počítači)

Pokud máte k počítači připojenu více jak jednu tiskárnu, můžete zde vybrat, která bude použita. Dále zde zvolte, jestli chcete tisknout všechny stránky jídelníčku a pokud ne, tak které. Případně můžete jídelníček vytisknout ve více jak jedné kopii. Tlačítkem Vlastnosti otevřete nastavení Vaší tiskárny, zde můžete nastavit zejména kvalitu tisku, pokud Vám standardní nevyhovuje.

Malé upozornění: Při tisku se vytisknou jen ta jídla, která byla na daný den opravdu zadána a uložena. Pokud chcete vytisknout nějaké jídlo jako prázdné (daný den bude u tohoto jídla prázdný řádek), otevřete editaci tohoto jídla v hlavním okně a zase ji zavřete tlačítkem Uložit, tím uložíte jídlo jako zadané, ale prázdné.
Naopak, pokud se Vám tiskne nějaké jídlo jako prázdné a Vy ho nechcete tisknout vůbec, smažte ho klávesou Delete v hlavním okně.

Zpátky na obsah

Zpracování souboru iObjednávek

Pokud využíváte systém internetového objednávání jídel firmy Barda, můžete nyní v aplikaci Lístky prohlížet soubory s objednávkami v přehledném formátu, případně je i tisknout. V menu Nástroje zvolte Zpracování iObjednávek. Objeví se dialog výběru souboru. Zde zvolte soubor iObjednávek, který chcete zpracovat. Objeví se okno náhledu, kde si můžete obsah souboru prohlédnout. S tímto oknem se pracuje stejně jako s oknem tisku jídelníčku.
V adresáři aplikace Lístky najdete ukázkový soubor iObjednávek pod názvem "iobj_ukazka.163".

Zpátky na obsah

Webová prezentace jídelny

Aplikace Lístky Vám nyní umožňuje vytvořit si na stránkách s jídelním lístkem i jednoduchou Internetovou prezentaci - zveřejněte základní informace o jídelně spolu s několika obrázky pro oživení na stránkách www.jidelna.cz! Nastavení webové prezentace najdete v menu Nástroje->Webová prezentace jídelny
Zde máme tři karty. Na kartě "Obrázky jídelny" vybíráte obrázky do své webové prezentace - celkem až čtyři. Tlačítkem "Vybrat" u příslušného pole zobrazíte dialog výběru obrázku. Obrázky musí být ve formátu JPEG (přípona JPG nebo JPEG). Pokud chcete obrázek smazat, klepněte na tlačítko "Prázdný".
Na kartách "Všeobecné informace" a "Provozní řád" pak můžete zadat další texty, které si návštěvníci Vašeho lístku budou moci prohlédnout. Změny se ve Vaší webové prezentaci projeví až po exportu dat na web. Pokud dojde k problémům s exportem, může se stát, že obrázky na Vaší webové prezentaci nebudou přesně odpovídat obrázkům, které jste vybrali v aplikaci Lístky. V takovém případě zaškrtněte volbu "Při příštím exportu odeslat všechny obrázky" a znovu odešlete data na web.

Zpátky na obsah

Tisk seznamu ID

Pro uživatele, kteří chtějí využívat Internetové objednávání LITE, ale nepoužívají program Jídelna, je zde možnost vygenerovat uživatelům ID, pomocí kterých budou moci objednávat. K tomu slouží položka "Tisk seznamu ID" v menu "Nástroje". Pro bližší informace ohledně této služby nás kontaktujte.

Zpátky na obsah

Aplikace Help Desk

Aplikaci Help Desk spustíte přes menu Nápověda volbou "Připojit se na Help Desk". Tato aplikace umožní přímé spojení Vašeho počítače se servisním technikem, který na něm pak může provádět zásahy, jako kdyby byl přímo u počítače přítomen. Tuto formu servisu je nutné předem dohodnout s konkrétním technikem firmy Barda (kontakty naleznete po spuštění aplikace). Služba se řídí podmínkami a ceníkem na stránkách firmy Barda.

Zpátky na obsah

Aktualizace programu přes Internet

V nabídce soubor zvolte Aktualizace. Program se připojí k aktualizačnímu serveru a zjistí, jestli jsou k dispozici nějaké aktualizace. Pokud ano, zobrazí se takovýto dialog:

V dialogu jsou uvedeny vylepšení v nyní dostupné verzi vůči Vaší. Pokud zvolíte Ano, stáhne se Vám aktualizační balíček. Balíček mívá přibližně 2 MB. Během stahování můžete pokračovat v práci, jakmile bude balíček stažen, budete vyzváni, abyste svou práci ukončili a umožnili dokončení aktualizace restartem programu:

A již máte na svém počítači nejnovější verzi aplikace Lístky!



Zpátky na obsah

Možné potíže a jak je vyřešit

Aplikace hned při startu vyhodí chybové hlášení.

Pravděpodobným důvodem je, že aplikace nemá přístup k databázím. To může nastat ze dvou důvodů:
1) Soubory zrovna používá jiná aplikace, pravděpodobně program Jídelna. Ukončete program Jídelna a zkuste to znovu.
2) Je špatně nastavená cesta k datovému úložišti. Při startu buďto budete přímo vyzváni, abyste vybrali složku s daty nebo ji vyberte v dialogu nastavení.

Když zadám v programu Jídelna jídelní lístek, nevidím ho v aplikaci Lístky a naopak.

Pravděpodobně jste při instalaci opomenul nastavit sdílení dat mezi programy Jídelna a Lístky. V dialogu nastavení vyberte cestu k datům aplikace Jídelna.



Zpátky na obsah

4. Dodatky

Co je nového v této verzi aplikace Lístky

Zpátky na obsah

Kontakty

Telefon: 241 495 088
E-mail: servis@barda.cz
Skype (www.skype.cz): HL-barda
WWW: www.barda.cz

Kancelář firmy:
Barda SW, HW s.r.o.
Jílovská 1100/16
142 00, Praha 4 - Braník

Sídlo firmy
Barda SW,HW s.r.o.
Akátová 134, Ohrobec - Károv
252 45 Zvole u Prahy
tel./fax: 257 760 687



Zpátky na obsah